Mikrotik RouterOS: Configurando um servidor PPPoE

Ainda que uma das grandes vantagens de usar o Mikrotik RouterOS seja a interface amigável do Winbox, vou ensinar a configurar um concentrador PPPoE através da CLI (Command Line Interface).

Abra o Winbox e entre no seu equipamento (PC, RB, CCR). Uma vez logado, clique na opção New Terminal, como na figura abaixo.

winbox_new_terminal

A partir daqui faremos tudo através de comandos. Vamos lá!

Vou pressupor que você tenha um acesso à internet através de um roteador que entrega o endereço ip por DHCP, ligado a interface ether1. Sendo assim vamos configurar o cliente de DHCP.

/ip dhcp-client add disabled=no interface=ether1

No item ip, subitem dhcp-client adicionamos uma instância atrelada à interface ether1, já habilitada.

 

Antes de configurar o servidor de PPPoE propriamente dito temos que definir quais IPs serão entregues através da configuração de um pool de IPs.

/ip pool add name=PPPoE ranges=172.16.0.2-172.16.0.254

Aqui criamos um pool com o nome PPPoE do qual serão entregues IPs de 172.16.0.2 até 172.16.0.254.

Em seguida criamos um perfil padrão e mais um perfil para cada plano de velocidade pretendido.

/ppp profile add change-tcp-mss=yes local-address=172.16.0.1 remote-address=PPPoE name="PPPoE" only-one=yes
/ppp profile add change-tcp-mss=yes local-address=172.16.0.1 remote-address=PPPoE name="2 MEGA" only-one=yes rate-limit=600k/2000k

Acima criamos um perfil de nome PPPoE vinculado ao pool previamente criado, chamado PPPoE e outro perfil chamado “2 MEGA PPPoE”, com limite de 2000k para download e 600 Kbps para upload. Definimos também que o IP local do servidor será o 172.16.0.1

E finalmente o servidor de PPPoE, associado ao perfil previamente criado.

/interface pppoe-server server add default-profile="PPPoE" disabled=no interface=ether2 max-mru=1480 max-mtu=1480 mrru=1600 one-session-per-host=yes service-name=PPPoE

Aí você pergunta: E as contas dos clientes? Realmente, está faltando isso. Quando criarmos as contas em secrets é que associaremos à um determinado perfil  (plano).

/ppp secret add disabled=no service=pppoe profile="2 MEGA" name=joao password=123

Pronto, é só criar uma conexão Banda Larga via PPPoE no Windows ou se conectar através de um roteador ligado na porta ether2 e verificar o resultado.

Não está navegando? É verdade. Faltou habilitar o NAT. Façamos isso!

/ip firewall nat add disabled=no chain=srcnat out-interface=ether1 src-address=172.16.0.0/24 action=masquerade

No item ip, subitem firewall adicionamos uma regra ativa na chain srcnat da tabela nat, tendo como porta de saída a interface ether1 e a ação masquerade afetando a rede 172.16.0.0/24.

  • Não cobri aqui a autenticação remota via Radius, que pode ficar para um próximo artigo.

Deixe uma resposta

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *